Skip to content
10/04/2008 / Thiago

Erro na Atualização do Ubuntu Hardy Heron 8.04 Beta

Opa! Vim aqui só para deixar a dica de alguém, como eu, está encontrando dificuldade para realizar algumas das atualizações que estão sendo lançadas para o Ubuntu Hardy Heron Beta. O erro que eu estava obtendo era quanto a configuração de vários pacotes, como mostro na mensagem a seguir.

E: libpango1.0-common: subprocess post-installation script returned error exit status 1
E: libpango1.0-0: dependency problems – leaving unconfigured
E: libgnomeui-0: dependency problems – leaving unconfigured
E: libgnome-desktop-2: dependency problems – leaving unconfigured
E: eog: dependency problems – leaving unconfigured
E: evolution: dependency problems – leaving unconfigured
(…)

Obviamente que a lista pode variar, mas o problema fundamental disso tudo é no momento que é tentado realizar alguma alteração nas fontes do sistema. O sistema Defoma realiza esse gerenciamento para o ambiente gráfico, de maneira que quando é tentado realizar alguma alteração, o apt encontra problemas e deixa como está, sem terminar de configurar o pacote. Assim começa uma reação em cadeia, onde o pacote x não é configurado porque o y não foi configurado por causa do w que também não foi configurado.

Para resolver o problema, basta o comando abaixo.

# defoma-reconfigure -f

Pronto! Depois disso basta um “apt-get upgrade” para reconfigurar todos os pacotes pendentes.

Abraços a todos!🙂

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: