Skip to content
17/08/2007 / Thiago

Aula 4 – Prova 640-801 – Roteamento IP

Nessa publicação discutiremos o processo de roteamento IP, os tipos de roteamento e os quatro protocolos de roteamento que são cobrados no exame CCNA 640-801: RIP, IGRP, EIGRP e OSPF. Os objetivos desse texto são:

  • Descrever o processo de roteamento
  • Descrever os protocolos de roteamento

Objetivo 1: Processo de Roteamento

Para começarmos a estudar o que é um processo de roteamento, precisamos definir o que é roteamento. Um conjunto de regras que definem como dados originado em uma determinada sub-rede devem alcançar uma outra seria uma boa definição para roteamento.

A função de roteamento cabe ao Roteador. Sua função é encaminhar pacotes de uma rede para outra. Ou seja, por padrão, ele não encaminha pacotes para uma mesma rede.

O processo de roteamento ocorre pois o roteador “aprende” sobre as redes a qual ele pode enviar pacotes, através das comunicações que possui com os roteadores vizinhos ou através de configuração manual de um administrador de sistemas. Com as rotas “aprendidas” o roteador pode criar a tabela de roteamento, sendo ela utilizada como referência para o encaminhamento dos pacotes.

A maneira como os roteadores constroem a tabela de roteamento determina se é realizado roteamento estático ou dinâmico. A característica fundamental do roteamento estático é a existência de intervenção manual no processo, através de regras criadas por uma pessoa. O roteamento dinâmico é justamente o oposto, onde existe um processo (protocolo de roteamento) que realiza a criação da tabela de roteamento de acordo com informações de roteadores vizinhos que também utilizem o protocolo de roteamento.

Roteamento Estático

As principais vantagens do roteamento estático são:

  • Redução da carga de processamento na CPU do roteador.
  • Não há uso da banda para troca de informações entre os roteadores.
  • Segurança rígida.

E as principais desvantagens do roteamento estático são:

  • Necessário profundo conhecimento da rede pelo administrador de rede.
  • A cada nova rede adicionada ao conjunto, será necessário adicionar manualmente informações sobre ela na tabela de roteamento.
  • Não é viável em grandes ambientes de produção, onde existam diversas redes e ambientes distintos.

ip route

Sintaxe:

ip route rede_destino mascara [endereco_proximo_hup|interface_saida] [permanent] [distancia_administrativa]

O comando ip route pode ser utilizado para a inserção manual de rotas em um roteador.

Exemplos de uso:

ip route 10.10.10.0 255.255.255.0 192.168.1.1

ip route 0.0.0.0 0.0.0.0 10.1.1.1

ip route 200.0.2.0 255.255.254.0 serial 2/0

O primeiro exemplo de uso criará uma rota para qualquer tráfego endereçado à rede 10.10.10.0/24 ser encaminhado para 192.168.1.1, que será um endereço diretamente contectado ao roteador. O segundo exemplo é uma rota padrão, assim como um default gateway, que encaminha tudo para o endereço 10.1.1.1. Rotas default apenas devem ser configuradas em redes chamadas stub, ou seja, redes que possuam apenas uma interface de saída, isso porque os roteadores utilizam essa rota apenas em último caso, caso não exista outra rota mais especĩf. O terceiro exemplo de uso criará uma rota para o destino 200.0.2.0/23 através da interface Serial 2/0 do roteador.

Ao se criar rotas estáticas, tenha em mente que todas as redes diretamente conectadas já têm rotas especĩficas para cada. O exemplo abaixo exibe toda a tabela de roteamento de um roteador.

Router#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is 10.11.210.1 to network 0.0.0.0

10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 10.1.1.1

Para que seja possível alcançar as demais redes pertencentes a rede, a tabela de roteamente deve então incluir informação que define onde as outras rede estão localizadas e como alcançá-las. A primeira letra em cada linha indica como foi “aprendida” a rota. No exemplo, a primeira regra indica que a rede 10.1.1.0/24 está diretamente conectada (C) ao roteador através da interface FastEthernet 0/0. A segunda linha indica uma rota padrão que foi adicionada estaticamente (S).

Outro detalhe é importante quando formos considerar o uso de rotas padrão: o comando ip classless. Todos os roteadores Cisco trabalham com redes classfull por padrão. Sendo assim, é necessário para o uso de rotas padrão o comando ip classless, para que o roteador também analise as sub-redes na tabela de roteamento. Do IOS 12.x em adiante, o comando ip classless encontra-se ativado por padrão.

Roteamento Dinâmico

As principais vantagens do roteamento dinâmico são:

  • Simplifica o gerenciamento da rede.
  • Viável em grandes ambientes de produção, com várias redes e ambientes diferentes.

As principais desvantagens do roteamento dinâmico são:

  • Utiliza larga de banda da conexão para troca de informações sobre roteamento entre os roteadores.
  • Consome processamento da CPU do roteador.
  • Menor controle, o que resulta em menor segurança do ambiente.

O processo de roteamento dinâmico utiliza protocolos para encontrar e atualizar tabelas de roteamento de roteadores. Os quatro protocolos de roteamento que iremos discutir são: RIP (Routing Information Protocol), IGRP (Interior Gateway Routing Protocol), EIGRP (Enhanced Interior Gateway Protocol) e OSPF (Open Shortest Path First).

Os protocolos de roteamento utilizados em redes pertencem a duas categorias: IGP (Interior Gateway Protocol) e EGP (Exterior Gateway Protocol). Protocolos IGP são usados para troca de informações entre roteadores pertencentes a uma mesmo Sistema Autônomo, que é uma coleção de redes sob um mesmo domínio administrativo. Já protocolos EGP são utilizados para comunicação entre roteadores pertencentes a Sistemas Autônomos diferentes. Protocolos EGP não fazem parte do escopo da prova CCNA 640-801.

Distâncias Administrativas

Distâncias Administrativas são métricas utilizadas para classificar a confiabilidade das informações recebidas por roteador através de seus vizinhos. A Distância Administrativa é um número inteiro entre zero e 255, sendo que quanto menor mais confiável é a rota. Ou seja, zero é a rota mais confiável e 255 indica uma rota inalcalçável.

Origem da Rota
Distância Administrativa Padrão
Interface diretamente conectada 0
Rota estática 1
Rotas Sumarizadas EIGRP 5
BGP 20
EIGRP Interno ao Sistema Autônomo 90
IGRP 100
OSPF 110
IS-IS 115
RIP 120
EGP 140
ODR (On Demand Routing) 160
EIGRP Externo ao Sistema Autônomo 170
BGP Interno 200
Desconhecido 255

Os protocolos de roteamento podem ser de três classes:

  • Vetor distância – Protocolos de roteamento classificados nessa categoria utilizam a distância à uma rede para definição do melhor caminho. A distância é medida de acordo com o número de roteadores que o pacote percorre até o destino (hup). Exemplo: RIP e IGRP.
  • Estado do link – Protocolos de roteamento classificados nessa categoria utilizam diversos fatores do nodo, como banda disponível, processamento, por exemplo, para identificar o melhor caminho. Exemplo: OSPF e IS-IS.
  • Híbrido – Protocolos de roteamento classificados nessa categoria possuem características de ambas as classes anteriores. Exemplo: EIGRP.

Objetivo 2: Protocolos de Roteamento

Vamos iniciar nosso estudo sobre os protocolos de roteamento e sua configuração em sistemas IOS. Iniciaremos estudando cada protocolo de acordo com sua categoria anteriormente mencionada.

Protocolos Baseados em Vetor Distância

O algoritmo de roteamento vetor distância envia as tabelas de roteamento completa para os roteadores vizinhos através de todas as interfaces ativas, que então combinam as tabelas recebidas com as tabelas que já possuem e completam o mapa da rede. Quando existem caminhos alternativos para o mesmo destino o fator da Distância Administrativa é levada em consideração pelo protocolo de roteamento.

O RIP, no entanto, utiliza apenas a contagem de saltos como métrica para a escolha do melhor caminho. Se houver dois caminhos com o mesmo custo, ou seja, a mesma quantidade de saltos para o destino, será realizado o round-robin load balance, ou seja, distribuirá a carga igualmente entre os links. Essa técnica pode ser aplicada até um máximo de 6 conexões com o mesmo custo.

E o que acontece quando ocorre uma mudança na topologia? Como o algoritmo realiza o envio da tabela de tempos em tempos, haverá um tempo para a convergência de todo o ambiente. No entanto, durante o período de convergência, nenhuma informações é transmitida, o que torna o tempo um fator crítico no processo. Um dos maiores problemas do RIP é seu intervalo de convergência demasiado alto.

Durante o período de convergência, podem ocorrer inconsistências nas tabelas de roteamento, ocasionando loops de roteamento. Para minimizar o efeito, algumas técnicas são adotadas, como descritas a seguir:

  • Contagem máxima de saltos (Maximum Hop Count) – uma maneira simples de evitar que sejam criadas referências infinitas na tabela de roteamento, é a definição de um limite para o número de saltos. No caso do RIP, o limite é até 15 saltos. Uma rede disponível apenas 16 saltos depois será considerada inacessível.
  • Split Horizon – solução em que o roteador que receber uma atualização da tabela de roteamento por uma interface não irá propagar o resultado pela mesma interface. Esse recurso é ativado por padrão em roteadore.
  • Envenenamento do Roteador (Route Poisoning) -faz com que no momento que um roteador detectar que seu vizinho possui uma tabela de roteamento com problemas, ele propaga para a rede que o vizinho estará a 16 saltos de distância, ou seja, inalcançável.
  • Holddowns – previne que uma mensagem regular de atualização reative uma rota que, na verdade, encontra-se inalcançável por algum motivo. Faz com que mudanças repentinas sejam efetivadas apenas de algum tempo.

Routing Information Protocol

Um dos protocolos mais utilizados e antigos de roteamento é o RIP (Routing Information Protocol). Suas características são:

  • Envia a tabela de roteamento completa para todas as interfaces a cada 30 segundos.
  • Utiliza apenas a contagem de saltos como métrica.
  • Limita a contagem máxima a 15 saltos consecutivos, ou seja, não é viável em redes de grande porte ou com muitos roteadores.
  • O RIP versão 1 utiliza roteamento classfull.

Para que o protocolo de roteamento mantenha-se ativo e disponível é necessário o uso de diversas técnicas para auxiliar em sua performance. O RIP utiliza a seguinte especificação:

  • Route Update Timer – Intervalo em que as atualização são enviadas. O RIP envia a cada 30 segundos.
  • Route Invalid Timer – Intervalo de tempo que deve ocorrer antes de um roteador determinar que uma rota tornou-se inválida. Essa conclusão será atingida se não ocorrerem atualizações sobre um determinada rotea até o fim do período. O RIP normalmente mantém um tempo de 180 segundos.
  • Route Holddown Timer – Intervalo de tempo que o roteador irá reter as atualizações entres de efetivá-las. O RIP normalmente mantém por um tempo de 180 segundos.
  • Route Flush Timer – Intervalo de tempo para remover uma rota que se tornou inválida. Antes de eliminar uma rota de sua tabela de roteamento, o roteador avisa aos vizinhos que determinada rota encontra-se inativa. O RIP normalmente espera por 240 segundos.

Configurando o RIP

A configuração do RIP é muito simples se comparada ao roteamento estático. Para iniciarmos a configuração do RIP é necessário remover todas as rotas estáticas que irão sobrepor os rotas geradas pelo RIP.

Router(config)#router rip
Router(config-router)#network 192.168.1.0

O exemplo acima irá configurar o RIP para propagar e receber informações através da rede 192.168.1.0. Não é necessário especificar uma máscara de rede, pois por padrão o RIP é classfull. Caso a rede tenha convergido, podemos verificar se o roteador já receber a rota.

Router#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

R 172.16.0.0/16 [120/1] via 192.168.1.2, 00:00:10, Serial1/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, Serial1/0

No exemplo, a rede 172.16.0.0 foi recebida através do protocolo de roteamento RIP, como constatado pela letra “R” no início da linha. Essa rede é acessível através da interface Serial 1/0.

Porém, em algumas situações pode não ser interessante que haja tráfego RIP ocorrendo em alguma das redes que um roteador está conectado. Para tanto, podemos limitar a propagação do RIP em alguma das interfaces com o comando passive-interface. Esse comando evita que uma atualização RIP seja propagada por uma determinada interface, porém, essa mesma interface continua a receber atualizações RIP.

Router(config)#router rip
Router(config-router)#passive-interface fastethernet 0/0

RIP Versão 2

O protocolo de roteamento RIP possui duas versões. Essa segunda versão do protocolo não é muito diferente da primeira versão, sendo que continua sendo um protocolo vetor distância e utilizando saltos como métrica. Basicamente em sua nova versão, o RIP suporta VLSM, CIDR, redes descontíguas e autenticação. Para o uso da segunda versão do RIP, basta o uso do comando abaixo.

Router(config)#router rip
Router(config-router)#version 2

Redes Descontíguas

Redes descontíguas são duas ou mais sub-redes de uma rede classfull, conectadas entre si através de uma rede classfull diferente. A figura abaixo representa bem isso.

Redes Descont�guas

Verificando a Configuração do RIP

Os seguintes comandos podem ser usados para verificação das configurações RIP:

  • show ip route – Apresenta toda a tabela de roteamento, incluindo as rotas aprendidas pelo RIP.
  • show ip route rip – Apresenta apenas as rotas aprendidas através do RIP.
  • debug ip rip – Envia as atualizações propagas e recebidas pelo roteador para a console.

Interior Gateway Routing Protocol

O protocolo IGRP, também classificado como sendo vetor distância, surgiu para suprir algumas necessidades que o protocolo RIP não possuía. Suas principais características são:

  • Protocolo proprietário da Cisco.
  • Contagem máxima de 255 saltos, sendo que o padrão é 100.
  • Utiliza a largura de banda e atraso da linha como métricas padrão para definição das melhores rotas, sendo que suporta outras métricas, como a segurança do meio, carga e MTU utilizado.

Da mesma maneira que o RIP, o IGRP também necessita de diversas técnicas para auxílio a sua performance.

  • Route Update Timer – O IGRP envia a cada 90 segundos por padrão.
  • Route Invalid Timer – O IGRP por padrão utiliza 210 segundos.
  • Holddown Timer – O IGRP por padrão utiliza 220 segundos.
  • Route Flush Timer – O IGRP utiliza 630 segundos, por padrão.

Configuração do IGRP

Assim como o RIP, a configuração do IGRP é bem simples, comparada à do roteamento estático. A única diferenteça entre configurar o RIP e o IGRP será que para o último é necessário a especificação do Sistema Autônomo a qual o roteador pertence.

Router(config)#router igrp 10
Router(config-router)#network 192.168.1.0

Podemos utilizar o comando show ip route para verificar a tabela de roteamento, da mesma maneira que fizemos com o RIP.

O IGRP pode também ser utilizado para balancear a carga entre quatro conexões desiguais. Redes RIP devem ter a mesma contagem de saltos para balancear a carga, já o IGRP utiliza a largura de banda para determinar como balancear a carga.

No entanto, o suporte ao IGRP no IOS foi descontinuado, dando lugar para o EIGRP, que será descrito nas próximas sessões.

Protocolos Baseados em Estado de Link

O algoritmo de roteador estado de link envia as tabelas de roteamento de acordo com modificações no ambiente, sendo que as atualizações são incrementais.

Open Shortest Path First

Não sendo o único exemplo de protocolo baseado em estado de link, o OSPF contém as seguintes características:

  • Protocolo aberto e padronizado pelo IETF, o que permite que diversas plataformas diferentes utilizam o mesmo protocolo de roteamento.
  • Utiliza o algoritmo SPF (Shortest Path First, também conhecido como Dijkstra) para definição do melhor caminho, de acordo com um custo. Cada interface de saída do roteador possui um custo associado, sendo que o custo total de um caminho é a soma dos custos de todas as interfaces que serão ultrapassadas no caminho.
  • Transmissão das atualizações da tabela de roteamento através de Multicasts, e não broadcasts, como o RIPv1.
  • Atualização incremental da tabela de roteamento, o que economiza a banda entre os vizinhos.
  • Divisão da rede em áreas. No entanto, o exame CCNA exige apenas conhecimento da configuração do OSPF em uma única área.

Com relação à areas, alguns conceitos são importantes terem sido definidos, mesmo que seja abordado o uso de apenas uma única área.

  • A área zero sempre deve existir em redes com mais de uma área. Essa área é conhecida como “backbone area”.
  • Todas as outras áreas devem sempre se conectar à área zero.
  • Áreas que não estão diretamente conectadas à área zero devem criar o artifício de virtuais-links.
  • Roteadores da área zero devem possuir uma capacidade de processamento elevada devido o alto tráfego que será corrento nessa área.

A figura abaixo demonstra um exemplo de rede OSPF.

Rede OSPF

A figura demonstra dois sistemas autônomos, sendo um seccionado em diversas áreas, com a área zero representando a área de backbone. Os roteadores pertencentes à área do backbone se chamam Backbone Router, às áreas que fazem conexão apenas com outras áreas internas são chamados ABR (Area Border Router) e o roteador que se comunica com outro sistema autônomo se chama ASBR (Autonomous System Border Router).

A tabela abaixo demonstra uma sumarização das principais características entre cada um dos protocolos até então estudados.

Característica RIP RIPv2 IGRP OSPF EIGRP
Tipo de Protocolo Vetor Distância Vetor Distância Vetor Distância Estado de Link Híbrido
VLSM não sim não sim sim
Sumarização automática sim sim sim não sim
Sumarização manual não sim não sim não
Redes descontíguas não sim não sim sim
Tipo de Propagação Broadcast Multicast (224.0.0.9) Broadcast Multicast (224.0.0.5 e 224.0.0.6) Multicast (224.0.0.10)
Métrica utilizada Saltos Saltos Composta Largura de banda Composta
Limite de saltos 15 15 255 N/A 224
Convergência Lenta Lenta Lenta Rápida Rápida
Autenticação Não Sim Não Sim Sim
Hierarquização Não Não Não Sim Não
Tipo de atualização Periódicas Periódicas Periódicas Eventuais Híbrido
Algoritmo adotado Bellman-Ford Bellman-Ford Proprietário SPF (Dijkstra) DUAL

Roteador Designado/Roteador de Backup Designado

O protocolo OSPF utiliza um artifício de eleger um roteador como DR (Designed Router) e outro como sendo substituto do primeiro, chamado BDR (Backup Designed Router). Esse roteador eleito como DR terá como tarefa a distribuição para todos da tabela de roteamento que será utilizada.

A eleição é realizada de acordo com a prioridade de cada roteador. O roteador com a a maior prioridade é eleito o DR para seu segmento e o com a segunda maior prioridade, o BDR. Se os valores de prioridade nos roteadores, no entanto, forem os padrões ou iguais, o Router ID (RID) de cada um é usado para o desempate. o RID é o maior valor IP configurado no roteador ou o IP de um interface de loopback, se cabível.
Caso seja necessário excluir um roteador do processo de seleção DR/BDR, basta configurar sua prioridade para zero. Sendo que a configuração de prioridades é realizado no modo de configuração da interface.

Router2(config)#interface serial 1/0
Router2(config-if)#ip ospf priority 2

Configurando OSPF

A configuração do OSPF irá se diferenciar dos protocolos de roteamento vistos anteriormente em pequenos detalhes. Vamos ao exemplo abaixo.

Router(config)#router ospf 1
Router(config-router)#network 10.1.1.0 0.0.0.255 area 0
Router(config-router)#network 192.168.1.0 0.0.0.255 area 0

A primeira linha indica que iremos entrar no modo de configuração de roteamento OSPF do processo 1. O número do processo é um dado irrelevante para o processo de roteamento, pois é apenas uma maneira de identificar unicamente e localmente o comportamento do OSPF em uma situação. Isso quer dizer, que podemos criar diversas instâncias do OSPF em um mesmo roteador. O valor do processo pode variar de 1 a 65.535.
A segunda linha irá realizar a divulgação das redes, da mesma maneira que feito no RIP e IGRP, com o diferencial de necessitar da máscara invertida, ou wildcard. A máscara invertida é, como o nome sugere, um máscara que reflete o inverso dos bits de uma máscara normal. Uma máscara comum 255.255.255.0 (que em binário é 11111111.11111111.11111111.00000000) terá como equivalente invertida o valor 0.0.0.255 (que em binário é 00000000.00000000.00000000.11111111). É interessante pensarmos em valores binários quando tratamos de VLSM ou CIDR. A máscara 255.255.224.0 (que em binário é 11111111.11111111.11100000.0) terá a wildcard 0.0.31.255.

Continuando a segunda linha, ao final, temos que identificar a área a qual esse rede será divulgada. Essa identificação da área pode ser através de um número natural ou um endereço IP (0.0.0.0 para a área zero).

Além da divulgação das redes, podemos configurar também o custo associado a cada interface do roteador. O OSPF já cria um custo automático para cada interface de acordo com a largura de banda, sendo que a fórmula é 10^8/(largura da banda). O custo pode ser modificado manualmente também, com um valor entre 1 e 65.535, como no exemplo abaixo.

Router2(config)#interface serial 1/0
Router2(config-if)#ip ospf cost 2000

Verificando a Configuração OSPF

Os seguintes comandos podem ser utilizados para verificarmos a configuração do OSPF.

  • show ip ospf – Apresenta informações importantes ao processo OSPF, como o número do processo, RID, e informações sobre a área. Caso existisse uma interface de loopback, seu valor seria utilizado como RID.
  • show ip ospf data – Apresenta uma informação mais resumida da anterior, indicando o estado de cada processo OSPF que estiver correndo localmente.
  • show ip ospf interface – Apresenta informações OSPF relacionadas à interface, como endereço IP, área OSPF, processo, RID, tipo de rede, custo, prioridade, informações DR/BDR quando possível, estado de envio de pacotes de estados da rede e informações sobre os roteadores adjacentes, ou seja, os vizinhos.
  • show ip ospf neighbor – Apresenta informações sobre o roteador adjacente.

Protocolos de Roteamento Híbridos

Alguns algoritmos de roteador Híbridos combinam o que existem de melhor entre os dois mundos: algoritmos vetor distância e algoritmos estado do link. Sendo assim, o comportamento pode ser algo único para cada protocolo, já que cada um irá escolher o que é mais adequado ao seu propósito.

Enhanced Interior Gateway Routing Protocol

O EIGRP é um protocolo do tipo classless, com algumas características de vetor distância como de estado de link. A Cisco algumas vezes refere-se ao protocolo como sendo vetor distância, vetor distância híbrido ou apenas híbrido. O EIGRP possui as seguintes características:

  • Suporte a VLSM, CIDR e sumarização de rotas.
  • Suporte a autenticação.
  • Limite de 224 saltos.
  • Suporta múltiplos protocolos de cada de rede (IPX, AppleTalk) além do IP.
  • Suporte a sumarização e redes não-contíguas.
  • Utiliza o algoritmo DUAL (Diffusion Update Algorithm) para inibir a formação de loops.
  • Troca de pacotes “hello” em tempos periódicos, de maneira a identificar caso algum vizinho pare de responder.
  • Troca de atualizações incrementais quando ocorrem mudanças na rede.
  • Envio da tabela completa de roteamento apenas quando é detectado um novo vizinho.
  • Apenas troca informações com vizinhos que pertençam ao mesmo sistema autônomo.
  • Provê balanceamento de carga em até quatro conexões desiguais (por padrão) ou seis ao máximo.

O EIGRP também utiliza-se de um protocolo proprietário chamado RTP (Reliable Transport Protocol) para gerência do fluxo de informações entre os roteadores. Quando o EIGRP não recebe uma resposta de algum dos vizinhos depois de um multicast, o RTP transforma o “hello” em unicast apenas para o vizinho indisponível. Se após 16 tentativas ainda não houver resposta, o vizinho é tido como “dead”.

Diffusion Update Algorithm

O EIGRP utiliza o DUAL para selecionar e manter em sua tabela de roteamento as melhores rotas para as redes. As principais funções desse algoritmo são:

  • Determinação de rotas alternativas quando possível. Essa rota alternativa chama-se “feasible succesor”, que é armazenada na tabela topológica (vista adiante). Um “succesor” é a rota primária, armazenada em ambas as tabelas topológica e de roteamento.
  • Suporte VLSM e CIDR.
  • Identificação dinâmica de rotas através de perguntas aos vizinhos.
  • Procura por rotas alternativas caso ele desconheça.

O EIGRP com o algoritmo DUAL oferecem um dos melhores tempos de convergência da rede. Suas vantagens para tornar isso possível são:

  • O EIGRP armazena toda as rotas que são recebidas pelos vizinhos, de maneira a construir uma tabela topológica em busca da melhor rota alternativa.
  • Caso o EIGRP não possua uma rota alternativa para um destino, o protocolo irá realizar um processo de “query” nos vizinhos, os questionando sobre a existência de alguma rota.

O EIGRP, como mencionado, mantém três tabelas em um roteador:

  • Tabela dos Vizinhos (Neighbor table) – informações sobre os roteadores vizinhos.
  • Tabela Topológica (Topology table) – informações sobre as rotas propagadas por cada vizinho.
  • Tabela de Roteamento (Routing table) – rotas que estão efetivamente em uso no momento.

Configuração do EIGRP

O EIGRP, assim como o RIPv2, não suportam redes descontíguas por padrão. Sendo assim, é necessário utilizar o comando no auto-summary sempre que for utilizar redes não-contíguas.

A configuração do EIGRP não possui maiores detalhes, como demonstrado no exemplo abaixo.

Router(config)#router eigrp 1
Router(config-router)#network 10.1.1.0
Router(config-router)#passive-interface f0/0
Router(config-router)#no auto-summary

A primeira linha irá realizar a entrada no modo de configuração do protocolo de roteamento. O último número indica o número do sistema autônomo a qual esse roteador irá participar.

A segunda linha exporta as redes que irão fazer parte do processo EIGRP de roteamento.

A terceira linha irá fazer com que a interface FastEthernet 0/0 não propague atualizações EIGRP, apenas recebendo.

A última linha irá desabilitar a sumarização automática de rotas, o que é necessário quando estamos trabalhando em redes descontíguas.

Verificando a Configuração EIGRP

  • show ip eigrp neighbor – apresentações diversas sobre o estado do protocolo EIGRP no roteador, como o tempo entre corrido entre cada “hello”, uptime de cada adjacência, controles de seqüência.
  • show ip eigrp topology – mostra a tabela de rotas EIGRP, com os feasible distance de cada. Além disso, mostra o estado de cada rota. É possível estar ativas ou passíveis. Quando um rota se encontra passiva, tudo está normal, e ela encontra-se inseria na tabela de roteamento. Quando uma rota encontra-se ativa, indica que a rota em questão não se encontra mais na tabela de roteamento e o EIGRP está “indagando” aos vizinhos se existe um caminho alternativo para a rota “perdida”.

Concluindo

Bem, é isso aí! O conteúdo pode ter ficado um pouco resumo demais na forma de itens, porém, pode servir como uma maneira simples de obter todas as informações de maneira simples.

Dúvidas, sugestões, algum tópico mais explanado, tudo terei o maior prazer em ajudar! É ajudando que se aprende, não é mesmo?🙂

Abraços a todos! Até mais!😀

7 Comentários

Deixe um comentário
  1. elvis / abr 7 2008 20:21

    queria informações mais afundo…

    obrigado…

  2. ThigU / abr 10 2008 11:26

    Olá Elvis,

    Que informações mais aprofundadas que gostaria?

    Abraços!

  3. fernando / abr 17 2008 16:48

    Muito obrigado pelo reumo.
    Vou passar a certificação agora em maio.
    Quais foram os topicos mais cobrados??
    Sairam muitas perguntas sobre switching? Acl?
    Nas perguntas com simulação, o que é que saiu?? Configuraçao de protocolos?
    Obrigado por responder

  4. ThigU / abr 17 2008 16:53

    Olá Fernando,

    Agora que faz um bom tempo que fiz a prova estou um pouco esquecido para lhe dizer maiores detalhes. Mas recomendo que leia outro post aqui no blog que falei exatamente de minhas experiências com a prova. Dê uma olhada no link abaixo.

    https://localdomain.wordpress.com/2007/08/26/menos-outra/

    Abraços!🙂

  5. Leandro Mendes / jul 24 2008 11:17

    olá,
    belo expliativo com as infos dos protocolos de roteament. nota 10

    abs!

    Leandro Mendes

  6. joao / fev 4 2009 9:35

    muito obrigado.
    agradeço o trabalho “perdido” na elaboração desta explicação

Trackbacks

  1. Menos Outra! « Where I can finally be calm…

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: